CoreShop Installation

You need a running instance of Pimcore on your system before you can install CoreShop.

You can setup your own example:

  • Allow dev version to be installed: composer config "minimum-stability" "dev" and composer config "prefer-stable" "true"
  • Install with composer composer require coreshop/core-shop ^3.0
  • Run enable Bundle command php bin/console pimcore:bundle:enable CoreShopCoreBundle
  • Run Install Command php bin/console coreshop:install
  • Optional: Install Demo Data php bin/console coreshop:install:demo

Payment

CoreShop uses Payum for Payment. Checkout Payums Documentation on how to add payment providers.

Payment providers are implemented as Pimcore Plugin. They can be installed using composer. Here you can find all available payment modules via composer

Payum Documentation